[OUTAGE] AKL-IX | v6 flap malformed attribute

Incident Report for New Zealand Internet Exchange

Resolved

This incident is resolved for now. A new notice will come out for route server maintenance to resolve this permanently by adding RFC 9234 role capability.
Posted Oct 08, 2025 - 17:05 NZDT

Monitoring

The offending malformed route is filtered upstream so no further impact is expected, we will place this on monitoring for now whilst work is underway to schedule emergency upgrades to the route servers to avoid this in the future.

The root cause appears to be a malformed OTC BGP update attribute typically 4-bytes but in this case was 1024 on the prefix 2402:2de0::/32, our route server software reflected this back to peers as expected and routers tore down their session due to it. The permanent fix for this is upgrading bird the BGP software on the route servers to not propagate these malformed attributes.
Posted Oct 08, 2025 - 11:00 NZDT

Investigating

We are currently investigating an issue that caused a flap on v6 sessions toward the route servers.
Posted Oct 08, 2025 - 10:35 NZDT
This incident affected: NZIX (AKL-IX).